Technical Requirements for On-line Games

These games work with Netscape 4/6/7, Microsoft Internet Explorer 5/6 and Firefox 1.0.1. However, certain security features of the newer browsers may prevent you from playing. In particular, Javascript must be enabled and Pop-up Blocking must be disabled (at least for this site). Here's how:

Return to the Games